Which .NET version do I need for Lightning?

You are here:

What is .NET?

Microsoft .NET is a framework with many standard software components that is installed on every Windows PC. Most software that runs on Windows uses .NET for basic functionality. Lightning needs .NET as well.

Which version do I need?

Lightning requires at least .NET Framework 4.8, which was released in April 2019.

Which version do I have?

If you have an updated Windows 7, Windows 8 or Windows 10 machine, you will have at least .NET Framework 4.8 installed. That means you can install Lightning directly.

If you are comfortable working with the Windows Registry, there are ways to find out which .NET version(s) you have installed.

Where can I download .NET?

You can download any .NET version from the Microsoft website. If you need to update .NET, install it before trying to install Lightning.