Which SOLIDWORKS versions are supported?

You are here:

Lightning runs on SOLIDWORKS 2018 and newer. We have tested Lightning with every version of SOLIDWORKS, from 2018 until 2022.

You only have to install an add-in once to be able to use it in every SOLIDWORKS version you have installed. So Lightning checks the SOLIDWORKS version when starting up.

Lightning only continues loading when it detects SOLIDWORKS 2018 or newer.

If a new version of SOLIDWORKS comes out, Lightning just continues working without needing an update.